PHP-Datums-Library fadoe/date überarbeitet

Es ist schon eine Weile her, als ich eine Datums-Bibliothek geschrieben habe. Heute habe ich diese auf den neuesten Stand gebracht, indem ich die Abhängigkeit auf PHP7 festgesetzt habe.

Was ist neu?

PHP7 ist schon lange auf dem Markt, PHP5 wird eigentlich nicht mehr unterstützt. Schon aus diesem Grund war es lange notwendig, die Bibliothek zu überarbeiten. Allerdings hatten sich damals noch einige kleine Fehler in den docblocks eingeschlichen, die ich gleich mit behoben habe.

Die aktuelle Version 0.8.0 gibt es auf Packagist unter https://packagist.org/packages/fadoe/date.